wmf files not displaying in browser

Aug 26, 2010 at 10:28 AM

I am using SilverlightContrib.Controls.Emf for displaying wmf format files in silverlight. It is showing the image in the designer view of xaml in visual studio but when i run the application I cannot see the image in browser, nothing is displayed there, also no error is coming up. Below is my xaml code. Please look into that and let me know whether I am missing something here.

 

<UserControl x:Class="SilverlightApplication7.MainPage"

xmlns:sc="clr-namespace:SilverlightContrib.Controls;assembly=SilverlightContrib.Controls"

xmlns:controls="clr-namespace:System.Windows.Controls;assembly=System.Windows.Controls"

xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

xmlns:d="http://schemas.microsoft.com/expression/blend/2008"

xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"

mc:Ignorable="d"    d:DesignHeight="300" d:DesignWidth="400">

<Grid x:Name="LayoutRoot" Background="Transparent">

<Grid.RowDefinitions>

<RowDefinition Height="*" />

<RowDefinition Height="Auto" />

</Grid.RowDefinitions>

<Button Content="Button" Height="23" HorizontalAlignment="Left" Margin="99,12,0,0" Name="button1" VerticalAlignment="Top" Width="75" Click="button1_Click" />

         <sc:Emf x:Name="emf" Stretch="Uniform" Margin="-76,63,76,-63" Grid.RowSpan="2" Visibility="Visible">

<sc:Emf.Source>                

<sc:EmfSource UriSource="farm.wmf" />          

</sc:Emf.Source>        

</sc:Emf>    

</Grid>   

</UserControl>